You are not logged in.

#1 2015-03-04 22:19:59

Sushiant
Member
From: Tehran, Iran
Registered: 2015-03-03
Posts: 8

following packages cannot be upgraded due to unresolvable dependencies

Hello to all;

First I would thank you (administrators and members) because of improving this project. I use of Ubuntu around 5 years and during that time, I could know a little about Fedora, Arch-Linux, and finally FreeBSD. I was thinking about a project like this {combination of Arch-Linux and BSD}. So Thank You very much for this adorable project. But now I have a problem to installing ArchBSD on my virtualbox.
I use 32bit Virtualbox on Ubuntu amd64 and would like to install this ArchBSD and taste it.
I have downloaded these versions (ArchBSD-i686-20140505.iso, ArchBSD-i686-20140527.iso, ArchBSD-x86_64-20140904.iso) Could not run x86_64. But in two another version of i686 which I can run on Virtualbox, there is a problem when try to install base.
The complete error message after

 pacstrap -C /tmp/pacman.conf /mnt base 

is:

:: The following packages cannot be upgraded due to unresolvable dependencies:
freebsd-configs          gcc-libs         pacman

Can you help me to solve this problem?
Thank You for everything ..

Last edited by Sushiant (2015-03-05 08:39:22)

Offline

#2 2015-03-04 22:24:14

rianav
Member
From: Between keyboard and chair.
Registered: 2013-07-17
Posts: 18

Re: following packages cannot be upgraded due to unresolvable dependencies

I'm sleepy so...
All I can think of is that the repo needs to be updated to solve this. Sounds temporary.  Maybe try again after the server is updated?

Regards,


China gangs burn pork on Amtrak while San Diego SWAT busts ice pirates at Target.

Offline

#3 2015-03-04 22:27:27

Sushiant
Member
From: Tehran, Iran
Registered: 2015-03-03
Posts: 8

Re: following packages cannot be upgraded due to unresolvable dependencies

Thank you for you quick reply.
Do you know when server is updated?
And what can I do now?

Offline

#4 2015-03-06 19:13:18

rianav
Member
From: Between keyboard and chair.
Registered: 2013-07-17
Posts: 18

Re: following packages cannot be upgraded due to unresolvable dependencies

Hi,
  Thinking more on this, perhaps the problem is the state of the i686 edition. Compared with the work going into amd64 ArchBSD.
  It seems from talk I have seen on the forum that manpower is lacking in the project. And amd64 edition gets more attention ATM.
  So if the problem persists over a period of days when attempting install of the i686, perhaps this is the reason. 
  Have you asked on the IRC channel?
  My internet is pretty slow, so trying a test install of the 32bit edition of ABSD would be non-trivial time-wise. Sorry I can't help further ATM. sad
  Please see https://bbs.archbsd.net/viewtopic.php?pid=553#p553

Best regards,

PS: I think the archbsd.net servers went down @ 23:30 4th Mar 2015  or so? hmm I was writing a new topic right after posting in yours & when submitting was informed that the bbs server was unreachable.

Last edited by rianav (2015-03-06 19:48:07)


China gangs burn pork on Amtrak while San Diego SWAT busts ice pirates at Target.

Offline

#5 2015-03-07 05:57:15

Amzo
Administrator
Registered: 2013-01-21
Posts: 144

Re: following packages cannot be upgraded due to unresolvable dependencies

Yes, i686 doesn't get much attention. It's only there if someone, or we in the future get time to work on it.

Offline

#6 2015-03-07 08:22:50

Sushiant
Member
From: Tehran, Iran
Registered: 2015-03-03
Posts: 8

Re: following packages cannot be upgraded due to unresolvable dependencies

Hi,

Thank You for everything you (rianav & Amzo and others) did about that.
OK, so maybe I need to change my virtualbox, because there is no 64-bit option of BSD and Linux and then try to install ArchBSD on it.

Best wishes
Sushiant

Last edited by Sushiant (2015-03-07 08:28:50)

Offline

Board footer

Powered by FluxBB