You are not logged in.

#1 2013-03-14 05:08:31

rsf
Member
Registered: 2013-02-07
Posts: 5

Installation in Virtualbox

Installation of ArchBSD under Virtualbox is straightforward, but I ran into a few issues running Virtualbox on linux that I figured I should share my solutions to:

- Ensure that 'Enable IO APIC' is checked under 'System'. This is disabled by default under linux.
- Select an 'Intel PRO' network adapter; the PCNet adapters do not work with {Free,Arch}BSD.

Otherwise everything should work as normal. I recommend picking your OS type/version as BSD/FreeBSD, unsurprisingly. You'll still need to run dhclient.

Last edited by rsf (2013-03-14 05:08:53)

Offline

#2 2013-03-14 08:32:22

Amzo
Administrator
Registered: 2013-01-21
Posts: 144

Re: Installation in Virtualbox

I'll enable automatic dhcp in the next iso release when I finish the new package set.

Offline

#3 2013-03-14 14:51:21

Embio
Member
Registered: 2013-03-14
Posts: 1

Re: Installation in Virtualbox

I installed ArchBSD under Virtual Box on the Arch Linux testing kernel last night without issue - what distribution are you using?

Offline

#4 2013-03-14 15:38:48

rsf
Member
Registered: 2013-02-07
Posts: 5

Re: Installation in Virtualbox

Arch Linux, 3.8.2-ck kernel. Perhaps your defaults were already set to the values I mentioned?

I found that other people were also having the same problem as me: [1] [2]

[1] http://lists.freebsd.org/pipermail/free … 24773.html
[2] http://forums.freebsd.org/showthread.php?t=28804

Last edited by rsf (2013-03-14 15:42:50)

Offline

#5 2014-08-09 00:18:34

neoxic
Member
Registered: 2014-08-09
Posts: 5

Re: Installation in Virtualbox

I assume 'Enable IO APIC' is set to ON by default if you choose the 'FreeBSD' guest when creating a virtual machine in the latest Virtualbox. I installed ArchBSD into Virtualbox on MacOS X, and that was the case. I also enabled 'Nested paging' as I did for my FreeBSD installation after having experimented throughout all possible combinations and measuring performance. 'Nested paging' doesn't do any good for my linux guests though including Archlinux.

Last edited by neoxic (2014-08-09 00:19:26)

Offline

Board footer

Powered by FluxBB